System performance discovery on my Tablet PC

Wednesday, November 2nd, 2005
For months I've been battling an irritating and elusive slow-down whenever I would attempt to do operations that involved windows explorer. Some times, these delays could be as long as 45 seconds. This became the source of tremendous humor to my friend, whom I shall not name, who, as a result, suggested that I was a deProductivity Specialist, not an eProductivity Specialist. (Sticks and stones, Michael)

Anyway, the short version of my discovery is that I found that I have either a bad SD card (which I usually keep in the SD card slot) or perhaps a problem with the built-in SD card reader in my M4. In any case, I removed the card and now my system zips along.

Apparently, as best as I can tell, the corrupt card (or reader) created a problem for windows explorer as each file operation causes explorer to consider all available devices, resulting in a significant delay when a device does not respond properly.

I don't think that this is the cause of all of my slow-down problems, but I now believe it's at least a major player.

Has anyone experienced this?

Discussion/Comments (7):

Eric, I’ve seen this on my Tosh M205 off and on

Eric, I've seen this on my Tosh M205 off and on; I believe you are generally correct as I only have the problem if I have an SD card in the slot. However, I don't believe the card or slot are bad.

I see the problem only with Windows Explorer functions, such as right-clicking on a file name for the context-menu options. When I do this, the menu takes time to pop up and my cursor responds intermittently or jumps around. I have difficulty navigating the menu, even with the keyboard. After what seems an etnernity, but is likely 30-45 seconds, the system begins responding again.

I have to wonder: would "stopping" the SD card reader in the System Tray help? I only just thought of this but it would be a good experiement for us to try. I'll give it a shot for a few days; let me know if you do the same.

Posted at 11/2/2005 1:11:54 PM by Kevin C. Tofel


System performance discovery on my Tablet PC

Hmmm, I just read a blog post a few days ago where the source of a similar slow down was network-related. I don't remember the gory details, but I believe it had something to do with some icon(s) causing the system to look for some file(s) on a network drive -- which was no longer available. Windows Exploder would hang while it searched for the network drive. It would eventually give up and begin to work, again.

Posted at 11/2/2005 4:08:28 PM by Scott


Network slowness, on XP/TPC platform

While I can demonstrate that the SD card is at least part of my slowness/jerkiness on my Tablet PC. I do suspect there's some network issue going on, too. (I even blogged about this a while back.) Thanks for the reminder. I'm going to find and disconnect any network connections (i.e. mapped drives) just to see if this makes a difference. So far, just removing the SD card has made a HUGE difference in performance.

Posted at 11/2/2005 5:16:09 PM by Eric Mack


System performance discovery on my Tablet PC

I experience the same thing on my Gateway MX275 except not only with an SD card in the reader, but memory Sticks too.

I'm going to bet this is a service pack issue, but darned if I've tried to troubleshoot it. I just take the card out.

Posted at 11/3/2005 5:23:48 AM by Jamie Price


System performance discovery on my Tablet PC

Most of the problems I experience on my system are due to Explorer. It's probably the only thing that crashes fairly regularly, usually citing ntdll.dll.

Internet Explorer is tied into this, too. With my Zen Micro MP3 player attached, everytime I go to the Address box, the player is activated (it shows as a device in My Computer) and I have to wait for it to converse with it before I can start typing...

Posted at 11/4/2005 6:33:20 AM by mbg


System performance discovery on my Tablet PC

Anything that must be polled by a WinXP box will cause significant slowdowns in the event the remote device is not available. This includes removable drives, removable media like SD, and especially mapped network drives. Windows Explorer allows a too-long polling before timeout IMHO which is the culprit. I have stopped using mapped drives so much on any portable computer that is prone to be in the situation of not being connected to those drives.

Posted at 11/6/2005 6:59:18 AM by James Kendrick


Does Firefox slow system performance too?

Does any other browser slow system performance or is this just an Internet Explorer problem?

Posted at 11/7/2005 8:40:51 PM by Tanny O'Haley


Mapped network drives and mobile computers

Eric Mack recently posted about a slowdown he is seeing on his Tecra M4 Tablet PC that happens when he is using Windows Explorer. He tracked the problem down to the use of an SD card, either a bad SD card or a problem with the SD reader itself. This jogged my memory to something similar I have seen occasionally pertinent to mobile computers and mapped network drives.

Posted at 11/8/2005 8:20:02 AM by OnTheRun: Using Mobile Devices Since They Weighed 30 lbs



Discussion for this entry is now closed.